// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\d{2,4}\/){2}\d\d\d\d.*\n\s+Logs are not written").unwrap();
let string = "12/20/2015 03:13:45 THis is text
Logs are not written
12/30/2015 04:13:45 THis is more text
Stuff happens
12/20/2015 03:13:45 THis is text
Logs are not written
Test THis
12/20/2015 03:13:45 THis is text
Logs are not written
Test THat on two lines
THis is the second line
12/20/2015 03:13:45 THis is text
Logs are not written";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}