using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2,4}\/){2}\d\d\d\d.*\n\s+Logs are not written";
string input = @"12/20/2015 03:13:45 THis is text
Logs are not written
12/30/2015 04:13:45 THis is more text
Stuff happens
12/20/2015 03:13:45 THis is text
Logs are not written
Test THis
12/20/2015 03:13:45 THis is text
Logs are not written
Test THat on two lines
THis is the second line
12/20/2015 03:13:45 THis is text
Logs are not written";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}