import re
regex = re.compile(r"(\d{2,4}\/){2}\d\d\d\d.*\n\s+Logs are not written", flags=re.IGNORECASE)
test_str = ("12/20/2015 03:13:45 THis is text\n"
" Logs are not written\n"
"12/30/2015 04:13:45 THis is more text\n"
" Stuff happens\n"
"12/20/2015 03:13:45 THis is text\n"
" Logs are not written\n"
"Test THis\n"
"12/20/2015 03:13:45 THis is text\n"
" Logs are not written\n"
"Test THat on two lines\n"
" THis is the second line\n"
"12/20/2015 03:13:45 THis is text\n"
" Logs are not written")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")