#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\b\d+\b),\s*(\btext\d+\b)"
Local $sString = "" & @CRLF & _
"CustomerID:1111," & @CRLF & _
"" & @CRLF & _
"text1" & @CRLF & _
"" & @CRLF & _
"CustomerID:2222," & @CRLF & _
"" & @CRLF & _
"text2" & @CRLF & _
"" & @CRLF & _
"CustomerID:3333," & @CRLF & _
"" & @CRLF & _
"text3" & @CRLF & _
"" & @CRLF & _
"CustomerID:4444," & @CRLF & _
"" & @CRLF & _
"text4" & @CRLF & _
"" & @CRLF & _
"CustomerID:5555," & @CRLF & _
"" & @CRLF & _
"text5" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")