$re = '/(\b\d+\b),\s*(\btext\d+\b)/';
$str = '
CustomerID:1111,
text1
CustomerID:2222,
text2
CustomerID:3333,
text3
CustomerID:4444,
text4
CustomerID:5555,
text5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);