# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b\d+\b),\s*(\btext\d+\b)"
test_str = ("\n"
"CustomerID:1111,\n\n"
"text1\n\n"
"CustomerID:2222,\n\n"
"text2\n\n"
"CustomerID:3333,\n\n"
"text3\n\n"
"CustomerID:4444,\n\n"
"text4\n\n"
"CustomerID:5555,\n\n"
"text5\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.