package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b\d+\b),\s*(\btext\d+\b)`)
var str = `
CustomerID:1111,
text1
CustomerID:2222,
text2
CustomerID:3333,
text3
CustomerID:4444,
text4
CustomerID:5555,
text5
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}