import Foundation
let pattern = #"(\b\d+\b),\s*(\btext\d+\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
CustomerID:1111,
text1
CustomerID:2222,
text2
CustomerID:3333,
text3
CustomerID:4444,
text4
CustomerID:5555,
text5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)