#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\S+\s+){3}jumped(?:\s+\S+){3}"
Local $sString = "" & @CRLF & _
" A quick brown cat jumped over the lazy dog." & @CRLF & _
" A quick brown monkey move over the lazy dog." & @CRLF & _
" A quick brown monkey jumped over the lazy dog."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")