re = /(?:\S+\s+){3}jumped(?:\s+\S+){3}/m
str = '
A quick brown cat jumped over the lazy dog.
A quick brown monkey move over the lazy dog.
A quick brown monkey jumped over the lazy dog.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end