using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\S+\s+){3}jumped(?:\s+\S+){3}";
string input = @"
A quick brown cat jumped over the lazy dog.
A quick brown monkey move over the lazy dog.
A quick brown monkey jumped over the lazy dog.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}