import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\S+\\s+){3}jumped(?:\\s+\\S+){3}";
final String string = "\n"
+ " A quick brown cat jumped over the lazy dog.\n"
+ " A quick brown monkey move over the lazy dog.\n"
+ " A quick brown monkey jumped over the lazy dog.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}