const regex = /(?:\S+\s+){3}jumped(?:\s+\S+){3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\S+\\s+){3}jumped(?:\\s+\\S+){3}', 'gm')
const str = `
A quick brown cat jumped over the lazy dog.
A quick brown monkey move over the lazy dog.
A quick brown monkey jumped over the lazy dog.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}