const regex = /settings\.([\w\.]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('settings\\.([\\w\\.]+)', 'g')
const str = `var serial = new serialport.SerialPort(settings.serial.port, { baudrate : settings.serial.baud, parser: serialport.parsers.readline("\\n") });
require("console-stamp")(console, settings.general.consoleLogDateFormat);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}