$re = '/settings\.([\w\.]+)/';
$str = 'var serial = new serialport.SerialPort(settings.serial.port, { baudrate : settings.serial.baud, parser: serialport.parsers.readline("\\n") });
require("console-stamp")(console, settings.general.consoleLogDateFormat);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);