using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'\w+#([0-9]+)'";
string input = @"'tex_to1#1234' 'texto2#5678' 'texto3#91011' 'texto4#121314' 'texto5#151617' 'texto6#18'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}