use strict;
my $str = '\'tex_to1#1234\' \'texto2#5678\' \'texto3#91011\' \'texto4#121314\' \'texto5#151617\' \'texto6#18\'';
my $regex = qr/'\w+#([0-9]+)'/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}