re = /'\w+#([0-9]+)'/
str = '\'tex_to1#1234\' \'texto2#5678\' \'texto3#91011\' \'texto4#121314\' \'texto5#151617\' \'texto6#18\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end