$re = '/\'\w+#([0-9]+)\'/';
$str = '\'tex_to1#1234\' \'texto2#5678\' \'texto3#91011\' \'texto4#121314\' \'texto5#151617\' \'texto6#18\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);