const regex = /'\w+#([0-9]+)'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'\\w+#([0-9]+)\'', 'g')
const str = `'tex_to1#1234' 'texto2#5678' 'texto3#91011' 'texto4#121314' 'texto5#151617' 'texto6#18'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}