import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<iframe.*?src=([\\\"\\'])https?:\\/\\/w{0,3}.?youtube.com.*?(\\2).*?\\>)(.*?)(\\<\\/iframe\\>)";
final String string = "<iframe src=\"http://youtube.com\" width=\"100\" height=\"200\">data</iframe>\n"
+ "<iframe src='http://youtube.com' width=\"100\" height=\"200\">data</iframe>\n"
+ "<iframe width=\"100\" src='http://youtube.com' width=\"100\"></iframe>\n"
+ "<iframe src=\"https://youtube.com\" width=\"100\" height=\"200\">data</iframe>\n"
+ "<iframe src='https://youtube.com' width=\"100\" height=\"200\">data</iframe>\n"
+ "<iframe width=\"100\" src='https://youtube.com\" width=\"100\">data</iframe>\n"
+ "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/tvrXet3Lx4U\" frameborder=\"0\" allowfullscreen></iframe>\n"
+ "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/tvrXet3Lx4U\" frameborder=\"0\" allowfullscreen>data</iframe>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}