import Foundation
let pattern = #"(<iframe.*?src=([\"\'])https?:\/\/w{0,3}.?youtube.com.*?(\2).*?\>)(.*?)(\<\/iframe\>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<iframe src="http://youtube.com" width="100" height="200">data</iframe>
<iframe src='http://youtube.com' width="100" height="200">data</iframe>
<iframe width="100" src='http://youtube.com' width="100"></iframe>
<iframe src="https://youtube.com" width="100" height="200">data</iframe>
<iframe src='https://youtube.com' width="100" height="200">data</iframe>
<iframe width="100" src='https://youtube.com" width="100">data</iframe>
<iframe width="560" height="315" src="https://www.youtube.com/embed/tvrXet3Lx4U" frameborder="0" allowfullscreen></iframe>
<iframe width="560" height="315" src="https://www.youtube.com/embed/tvrXet3Lx4U" frameborder="0" allowfullscreen>data</iframe>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)