# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<iframe.*?src=([\"\'])https?:\/\/w{0,3}.?youtube.com.*?(\2).*?\>)(.*?)(\<\/iframe\>)"
test_str = ("<iframe src=\"http://youtube.com\" width=\"100\" height=\"200\">data</iframe>\n"
"<iframe src='http://youtube.com' width=\"100\" height=\"200\">data</iframe>\n"
"<iframe width=\"100\" src='http://youtube.com' width=\"100\"></iframe>\n"
"<iframe src=\"https://youtube.com\" width=\"100\" height=\"200\">data</iframe>\n"
"<iframe src='https://youtube.com' width=\"100\" height=\"200\">data</iframe>\n"
"<iframe width=\"100\" src='https://youtube.com\" width=\"100\">data</iframe>\n"
"<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/tvrXet3Lx4U\" frameborder=\"0\" allowfullscreen></iframe>\n"
"<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/tvrXet3Lx4U\" frameborder=\"0\" allowfullscreen>data</iframe>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.