use strict;
my $str = '<iframe src="http://youtube.com" width="100" height="200">data</iframe>
<iframe src=\'http://youtube.com\' width="100" height="200">data</iframe>
<iframe width="100" src=\'http://youtube.com\' width="100"></iframe>
<iframe src="https://youtube.com" width="100" height="200">data</iframe>
<iframe src=\'https://youtube.com\' width="100" height="200">data</iframe>
<iframe width="100" src=\'https://youtube.com" width="100">data</iframe>
<iframe width="560" height="315" src="https://www.youtube.com/embed/tvrXet3Lx4U" frameborder="0" allowfullscreen></iframe>
<iframe width="560" height="315" src="https://www.youtube.com/embed/tvrXet3Lx4U" frameborder="0" allowfullscreen>data</iframe>';
my $regex = qr/(<iframe.*?src=([\"\'])https?:\/\/w{0,3}.?youtube.com.*?(\2).*?\>)(.*?)(\<\/iframe\>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}