#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "LogFile Alert: Pattern 'Memory queue for message type 1: 3038' found "
Local $sString = "LogFile Alert: Pattern 'Memory queue for message type 1: 3038' found in /var/log/me"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")