using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"LogFile Alert: Pattern 'Memory queue for message type 1: 3038' found ";
string input = @"LogFile Alert: Pattern 'Memory queue for message type 1: 3038' found in /var/log/me";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}