package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`LogFile Alert: Pattern 'Memory queue for message type 1: 3038' found `)
var str = `LogFile Alert: Pattern 'Memory queue for message type 1: 3038' found in /var/log/me`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}