const regex = /LogFile Alert: Pattern 'Memory queue for message type 1: 3038' found /;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('LogFile Alert: Pattern \'Memory queue for message type 1: 3038\' found ', '')
const str = `LogFile Alert: Pattern 'Memory queue for message type 1: 3038' found in /var/log/me`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}