// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"LogFile Alert: Pattern 'Memory queue for message type 1: 3038' found ").unwrap();
let string = "LogFile Alert: Pattern 'Memory queue for message type 1: 3038' found in /var/log/me";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}