import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\.ru)$";
final String string = "www.badguy.com\n"
+ "badguy.com\n"
+ "www.badguy.com.ru\n"
+ "www.badguy.com.ru/attack\n"
+ "long.sub.domain.url.ru\n"
+ "long.sub.domain.url.ru/attack\n"
+ "randomjdhflerrflerfluerfh.ru\n"
+ "randomjdhflerrflerfluerfh.ru.com\n"
+ "www.rubicon-project.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}