$re = '/(\.ru)$/m';
$str = 'www.badguy.com
badguy.com
www.badguy.com.ru
www.badguy.com.ru/attack
long.sub.domain.url.ru
long.sub.domain.url.ru/attack
randomjdhflerrflerfluerfh.ru
randomjdhflerrflerfluerfh.ru.com
www.rubicon-project.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);