const regex = /(\.ru)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\.ru)$', 'gm')
const str = `www.badguy.com
badguy.com
www.badguy.com.ru
www.badguy.com.ru/attack
long.sub.domain.url.ru
long.sub.domain.url.ru/attack
randomjdhflerrflerfluerfh.ru
randomjdhflerrflerfluerfh.ru.com
www.rubicon-project.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}