import re
regex = re.compile(r"(\.ru)$", flags=re.MULTILINE)
test_str = ("www.badguy.com\n"
"badguy.com\n"
"www.badguy.com.ru\n"
"www.badguy.com.ru/attack\n"
"long.sub.domain.url.ru\n"
"long.sub.domain.url.ru/attack\n"
"randomjdhflerrflerfluerfh.ru\n"
"randomjdhflerrflerfluerfh.ru.com\n"
"www.rubicon-project.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")