re = /(\.ru)$/m
str = 'www.badguy.com
badguy.com
www.badguy.com.ru
www.badguy.com.ru/attack
long.sub.domain.url.ru
long.sub.domain.url.ru/attack
randomjdhflerrflerfluerfh.ru
randomjdhflerrflerfluerfh.ru.com
www.rubicon-project.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end