#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:<span data-prefix="([^"]+)">([^<]+)<\/span>)+"
Local $sString = "<div class="set">" & @CRLF & _
" <span data-prefix="[1]">Duck</span>" & @CRLF & _
" <span data-prefix="[2]">Dog</span>" & @CRLF & _
" <span data-prefix="[3]">Cat</span>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")