// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:<span data-prefix="([^"]+)">([^<]+)<\/span>)+"#).unwrap();
let string = "<div class=\"set\">
<span data-prefix=\"[1]\">Duck</span>
<span data-prefix=\"[2]\">Dog</span>
<span data-prefix=\"[3]\">Cat</span>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}