package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:<span data-prefix="([^"]+)">([^<]+)<\/span>)+`)
var str = `<div class="set">
<span data-prefix="[1]">Duck</span>
<span data-prefix="[2]">Dog</span>
<span data-prefix="[3]">Cat</span>
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}