re = /(?:<span data-prefix="([^"]+)">([^<]+)<\/span>)+/
str = '<div class="set">
<span data-prefix="[1]">Duck</span>
<span data-prefix="[2]">Dog</span>
<span data-prefix="[3]">Cat</span>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end