using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<span data-prefix=""([^""]+)"">([^<]+)<\/span>)+";
string input = @"<div class=""set"">
<span data-prefix=""[1]"">Duck</span>
<span data-prefix=""[2]"">Dog</span>
<span data-prefix=""[3]"">Cat</span>
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}