package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(?:https?:\/\/)?(?:www\.)?[a-zA-Z0-9./]+$`)
var str = `example.com
www.example.com
http://example.com
https://www.example.com
example.com/exam1/exam.php
example.com/exam`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}