import re
regex = re.compile(r"^(?:https?:\/\/)?(?:www\.)?[a-zA-Z0-9./]+$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("example.com\n"
"www.example.com\n"
"http://example.com\n"
"https://www.example.com\n"
"example.com/exam1/exam.php\n"
"example.com/exam")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")