import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:www\\.)?[a-zA-Z0-9./]+$";
final String string = "example.com\n"
+ "www.example.com\n"
+ "http://example.com\n"
+ "https://www.example.com\n"
+ "example.com/exam1/exam.php\n"
+ "example.com/exam";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}