re = /^(?:https?:\/\/)?(?:www\.)?[a-zA-Z0-9.\/]+$/im
str = 'example.com
www.example.com
http://example.com
https://www.example.com
example.com/exam1/exam.php
example.com/exam'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end