const regex = /^(?:https?:\/\/)?(?:www\.)?[a-zA-Z0-9./]+$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?(?:www\\.)?[a-zA-Z0-9.\/]+$', 'gim')
const str = `example.com
www.example.com
http://example.com
https://www.example.com
example.com/exam1/exam.php
example.com/exam`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}