use strict;
my $str = ' 2 >= 1 2 > 1';
my $regex = qr/>[=]?/ip;
my $subst = 'EQUAL';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";