import Foundation
let pattern = #">[=]?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #" 2 >= 1 2 > 1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"EQUAL"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)