package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\d.]+)(\d[\d.e+-]*)`)
var str = `Height_A_B132width_top100.0lengthsimple0.00001
Height_A132width_top100.0lengthsimple1.34e+003
be12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}