import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\d.]+)(\\d[\\d.e+-]*)";
final String string = "Height_A_B132width_top100.0lengthsimple0.00001\n"
+ "Height_A132width_top100.0lengthsimple1.34e+003\n"
+ "be12";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}