// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^\d.]+)(\d[\d.e+-]*)").unwrap();
let string = "Height_A_B132width_top100.0lengthsimple0.00001
Height_A132width_top100.0lengthsimple1.34e+003
be12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}