re = /([^\d.]+)(\d[\d.e+-]*)/
str = 'Height_A_B132width_top100.0lengthsimple0.00001
Height_A132width_top100.0lengthsimple1.34e+003
be12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end